RAF Coningsby FS9

The scenery is available for FS2004 and FSX "out of the box" and FSX with the SP1 patch. IT IS NOT COMPATIBLE WITH SP2 and ACCELERATION.

RAF Coningsby Forum